Back to overview
Downtime
Pccom update in progress. 2..3 min downtime
May 05 at 07:05am CEST
Affected services
pCCom
Resolved
May 05 at 07:09am CEST
pccom update is finished.
Affected services
pCCom
Created
May 05 at 07:05am CEST
Pccom update
Affected services
pCCom